Thursday, January 31, 2013

Transparent magic smoke

Yes, not blue, not black or even white! Transparent, which only adds a layer of difficulty to find the leaked bottle...

I was trying to find the instability on 40m when I think I overdrive the "Speaky" releasing some smoke, OK it was not actually smoke but for sure something bad happened and now although it looks like I have transmission signal (didn't tested any longer) I don't have reception (but have audio) and I can ear the mic audio in the output speaker... something I couldn't earlier, so it can't be that bad....

Without further testing I dare to say that the problem is near pin 24 (see schematic,) be it further down or up on the tx/rx switching part. At least T30 isn't conducting during RX, that's why audio bypasses to the balanced modulator and I can listen to it on the speaker, so in that order of idea the balanced modulator is working also.... that leaves T27 to be a good candidate to the recycle bin....

Eventually it can be one of the switching diodes reversing near the mixer (not shown in this part of the schematic) but I would bet more on T27...

Well, more fun for the weekend...

Tuesday, January 29, 2013

My other transceiver...'s also junk!...nah, it's a Ferrari :)

At some point during construction:

I had to remove the IF amp for another project so right now it's unusable but it worked! I never placed a low-pass filtering so it's also not advisable to transmit. That's another project to be finished one of this days.

Meanwhile the "Speaky" log it's getting bigger every day and I broke the 10 QSO milestone! I have to say without a lot of effort..well some directional antennas in the other end made this miracle happen.

LX1HD (1606.4 km)
IZ8GUU (2103.2 km)
HB9ETH/M (1603.6 km)
GM4WZL (1795.3 km)
OK2JS (2237.6 km)
IZ2ZEX (1592.5 km)

DA1YS  (1733.8 km)
GI4SNA  (1658.3 km)
S52WW  (1990.2 km)
DL1WM  (1737.2 km)

All on 17m.

I measured power on a homebrew, not calibrated, power meter and the Speaky outputs 12W but on the same meter the FT-817 outputs 8W so I guess more real values by analogy would be 5W to the FT-817 and 8W (considering voltages to power) to the Speaky. Not bad any way.

There's still plenty to do before closing the lid:

  Add heat dissipation to the final transistors.
Check audio compression/gain issue
Trim PA bias
Calibrate internal power/S-meter
Tighten cables.
Optimize IF filter bandwidth, now its a little wide for my taste. (will be left like it is)
Rebuild 40m bandpass filter, it works but trimmers are on the lowest capacity setting.
Add 20, 15 and 10m band.... 30,20,15,12 and 10m band
Modify internal speaker mount, audio is to much on the low (bass) side
Add another audio amp, the existing one stays just for headphones
Check drive level on 40m that is generating some instability

Have a nice week!

Thursday, January 24, 2013

6 in the log

So far, I have 6 QSO's in the "Speaky" log, all on 17m, by order:


I already copied some DX stations like HZ1TT (Saudi Arabia) and W1AW (ARRL headquarters) but could not work them, first due to the pile-up and second the operator just stayed a short time. Propagation is also not specially high at this moment.

On 40m (LSB) I still have lower power than 17m (USB), which I found is related to the IF filter so will tune BFO using a sound card instead of ear truing. My antenna is not tuned either for 40m.

The radio promises, as I predicted, it's just limited in terms of output power and since I'm not a fundamentalist of QRP maybe one day will try to build an amp for it.

Will change also the audio amp because it's a little on the low side for my preferences but it's nice for headphones.

Here's the parts that came extra with the kit (much better than missing):

Not much; half a dozen resistors, 1 IC (strange), some wire, one 1n4148 and probably 3 capacitors.

Have fun!

Monday, January 21, 2013

Black out

Saturday morning, I wake up with some strong winds, the weather report was stating a red alert (second most dangerous) for most part of the country including Leiria were I live and Peniche, my parens, the predicted top wind-gusts were to be around 120Km/h. I went to the shack, hoping none of the antennas would fly and I could copy fellow blogger Bas (PE4BAS) activating a castle in the Netherlands, a quick tune around on 20m but no luck, after a little bit experienced a power outage, I could had switched to battery backup power but since I told my parents I would drove to their home decided to stop radio activities.

As predicted by the weather report, wind was really a bit on the strong side so decided to postpone the trip for latter in the afternoon hopping condition improvement.

When I bought my house my priorities in getting furniture were: a good bottled gas water heater, candles and a fire extinguisher....
The fire extinguisher is a must due my nature to make things leave some smoke, specially cooking...
Candles; When I was a kid an lived in Peniche it was normal in windy days to be left without electricity for some time so we had always candles and petrol powered lights. I've not experienced many faults now in Leiria but I like to be always ready.
A good water heather; well I'm not Finish (no offense) so I don't like very much of having a cold bath and sauna is not a tradition here also :)

Time went by and electric power wouldn't came back, so I hit the road to my parents. Wind was already lower and I thought I could make a safe trip, especially since my little daughter would come with me.
While preparing to the road trip I thought of taking the portable VHF/UHF radio, just in case, instead took the Swiss army knife, for sure much more handy in case I have to stop for some fallen tree of road debris.

Here's a nice quote from KE9V about a similar subject:

"...In a complete meltdown on a national (or global) scale there would be no one to call for help. In that case, I suppose two-way radio could be used to confirm that folks a thousand miles away are just as screwed as you are?..."
I think the quote says it all...
The brighter lights during my road trip to Peniche were my car lights, all villages until very close to my parents were all in a black out from the grid and the road was full of small debris from the trees, luckily fireman had already cut'd all the trees that had fall on the road during the morning high winds.

Electricity eventually returned to Leiria on Sunday morning, lucky me that my parents didn't experienced the power outage so I had a comfortable Saturday evening and a nice Sunday morning. From what I heard in the news there are still some small villages without power and even water.

Another side effect of this storm was that the antenna mast at my parents didn't hold the strong winds, it was a hardware corrosion problem, Peniche is a peninsula just in the path of the salty Atlantic winds, no metal holds good for live. Have to put a new mast next week.

Here's a video with some photos of the storm and damage in Peniche:

Now as I'm writing this post back in Leiria the water is getting low pressure, just as I predicted. This afternoon I bottled some water just in case :)
Let's hope it's only temporarily. Else I have to go to the river :) there's absolutely no water, f"#$%!"#$#", getting better every minute...
...No all is bad, temperature is not going bellow 13ºC, people in northern latitudes are worse in this matter!

p.s.: There's a second QSO in the log using the "Speaky", this time the "victim" was IZ8GUU whom I answered the CQ on 17m.

An update list to do on the "Speaky":

Add heat dissipation to the final transistors.
Check audio compression/gain issue
Trim PA bias
Calibrate internal power/S-meter
Tighten cables.
Optimize IF filter bandwidth, now its a little wide for my taste.
Rebuild 40m bandpass filter, it works but trimmers are on the lowest capacity setting.
Add 20, 15 and 10m band.... 30,20,15,12 and 10m band

Have a nice week!

Have a nice week.

Sunday, January 20, 2013

A special QSO

I had said to myself, long time ago, that I would only consider myself an reasonable amateur if I managed to build and make a QSO with something I built instead of using an appliance. I don't say all ham's should follow my idea, each one should have is own goals.

Keeping short, some time ago I built an VHF FM transceiver (with some small parts designed by me on the reception chain) and made at least 2 QSO's... before reusing some components to another project (a VHF crystal controlled transmitter, unfinished so far). It was a nice feeling of accomplishment but I wanted to make also a QSO in the HF bands using something soldered my me.

Last Friday I was doing some adjustment in the "Speaky" transceiver BFO and band pass filter for the 17m band when I heard someone CQ'ing, I couldn't resist and answered the call, first a brief "QRZ" and finally LX1HD (1600Km from my QTH) managed to decode my call-sign... YES!!! I was so nervous like it was my first ever QSO because I still didn't placed the heath dissipator on the final transistors and they are somehow expensive, kept the QSO very short and asked for an audio report, Henri answered stating some RF present in the signal which latter traced to the audio compression part. I thanked a lot to Henri and said goodbye because I was very afraid of blowing the finals.  Think I even didn't sent Henri his signal report but was at least 59....the s-meter isn't calibrated yet as so is the output power meter...!

 Here it is as when QSO was made:
 Bench testing the unit:

Now some things to do before closing the top lid and have fun QSO'ing:

Add heat dissipation to the final transistors.
Check audio compression/gain issue
Trim PA bias
Calibrate internal power/S-meter
Tighten cables.
Optimize IF filter bandwidth, now its a little wide for my taste.
Rebuild 40m bandpass filter, it works but trimmers are on the lowest capacity setting.
Add 20, 15 and 10m band....

 ...Maybe my next objective could be someday design an built everything from the ground up....maybe

Have a nice week!

Thursday, January 17, 2013

4 mistakes

Considering the sheer amount of connections and components I wasn't expecting 0 errors building the kit.... but from what I found so far none made were critical to the transceiver function. Here's the mistakes description:

* Frequency on the frequency counter: I was getting strange behavior from the frequency counter, the frequency was offset for some 500Khz, if it was by the IF frequency I could suspect on mixing effects or something, but 500Khz?... I finally thought it should be the code on the PIC, started to look around and guess what, the supposed 4Mhz clock crystal for the PIC was an 8Mhz one, how this happened I don't know but it's probable that an 8Mhz crystal came with the kit instead of the 4Mhz one. Replaced and now it's spot on.

* IF gain control: Was counterclockwise increasing, changed to "standard" settings.
* Drive power/RF output control: Was counterclockwise increasing, changed to "standard" settings.

* 40m bandpass filter: Not actually an error, it was working from the beginning but with marginal settings so will try to improve a little bit, anyhow can now listen to CT and EA stations with just 2m of wire connected to the "Speaky" antenna terminal inside the shack.

Now some photos on the "Speaky" parts:

40m band module:
Main board, frequency counter, band module, low pass filters:

Next steps:

* Finishing the 17m band module 

* Testing the first transmission

Have reception on the 17m band, have transmission audio and RF power but it was just a quick test, I have to tune all the transmission path settings first.

See you!

Monday, January 14, 2013

My new rig...

My first rig was a Kenwood TS-50, at that time it wasn't cheap but it was the cheaper rig in the market (new). It has been serving me nice and I still own it.

Now, after learning a little bit more about the hobby, made me realize I needed something different....

OK, I know, it's probably a little on the expensive side but think about the joy of operating this little rig, and when you made a QSO you can tell with all the pride the model of your equipment and talk about all the bells and whistles, you can even mention it can make tea and toasts...

 It's for sure a pileup breaker...besides the bank account...

So without more delays.... it is.... new rig after the first successful real air transmission copy on 40m band...
It was with about 1m of wire connected directly to the first mixer amp since I haven't found yet the issue in the bandpass filter or in the 33Mhz low pass part (another possible candidate for the problem)....

(an old photo but same model)

Will keep debugging the next few days but at least half the rig works!!! I'm happy!

Saturday, January 12, 2013

Hot tip

..Ok, I fixed the soldering iron heater, eg: bought a new one, for the price I could have bought 4 cheap soldering irons but probably would not last the same time so I stick with this one since I'm already used to shape and size.

After getting again some heath from the soldering tip I finished re-cabling the Speaky, minus the external cw key but will solder those 3 wires in a near future.

Also a better cable routing will be finished after getting this QRP "beast" to full working condition :)

I powered it on and kind of worked..... have noise, good! Had a little problem in the frequency display, I programed it wrongly and the most interesting/strange stuff is when I disconnect the counter signal input the radio enters TX mode. I changed nothing and now it's OK on that issue but now sometimes it doesn't count....go figure, not critical for now I'm measuring VFO frequency with my external frequency counter....

All controls work but can't see much change from the pre-selector, more on this latter.
Here's an idea on the parts involved:

I can receive an 8 Mhz (the IF) signal from the frequency generator and a big signal on the 40m band (the only band module connected for now) transmitted from the FT-817 to a dummy load, still real air transmission got none so far. Will have to debug but I'm thinking that could be an issue from the bandpass filter or the first rf amp part before the first mixer, more debug on the next days....
Didn't checked transmission part so far.

Here's a global view of the receive part:

Have a nice weekend...

Tuesday, January 08, 2013

Cold heather

Yesterday I notice the soldering iron getting cold, immediately checked mains power (just looked at the soldering table light) and then I thought maybe the cable entering the iron handle got broken, twisted it a little bit and looked like the problem was over.... today I continued re-cablling the "Speaky" and at some point the soldering iron got cold again, this time it didn't resuscitate....

...and yes I checked continuity on the!
 It was a "good" friend for over 8 I have to buy a replacement heather element which is roughly half the price of a new iron....

...and you still have to have another iron to solder the new element.

One thing that is lasting less than expected was the new tip I bought two years ago

the original one and the one afterward lasted much lounger, probably their reducing manufacturing costs or outsourcing...

Saturday, January 05, 2013

Speaky re-cabling

Built once....building twice!

Was not happy with cables on the first try so will go for round two, this is a major task since none of the external parts fix directly to the main board...

I suspect that a lot of debug will have to be made afterwards since it's easy to fail somewhere along the path and the "Speaky" it's a very big project.

The blue color cables are all new, now they have enough length and will allow me to push back the front panel for main board inspection and debugging.
 ...meanwhile I broke the pre-selector pot. Can you believe that both electronics shop in town don't have the 10K linear value en stock?

Not doing it fast and not a priority for sure but I would like to finish the kit during this century.

Have a nice weekend!

Wednesday, January 02, 2013

VFO wave

I decided to have a closer "look" on the 1972, 73 magazine VFO circuit from a previous post.

The circuit (minus the red part):

The setup:

 ..coil is from an old IF transformer and the tank cap was the first on hand...
turns out it oscillates at:


Now the output wave with "post processing" markers...:

 ...period is almost one division (10uS).
it's not a perfect sine even when "stretched":

 ...almost 8uS of period (4 divisions), that translates to 125Khz, close to the measured 137Khz (7.3uS), a normal error due to optical and timebase factor..

...will try other oscillator circuits in the future searching for the perfect wave....

Have a great 2013!